PDA

View Full Version : Neverwinter Nights Issue...



CheshireEyes
October 30th, 2007, 11:40 PM
So, I'm a Ranger (Level 7 presently) and I've had the abilitiy to call an animal familiar (i picked the panther) since level six, but I CAN'T do it, I can use my ranger spells and stuff but when I try and call my animal familiar from my special abilities it won't let me, the only thing I can do is cast defensive magic or something. I tried taking off my armor on the off chance that it was giving me a problem as if I were a mage, but no such luck. Anyone know what I'm doing wrong here? Its not like the normal spells where you assign it a spot and then rest to memorize them and the manual isn't helpful at all. Any help would be appreciated. Thanks, peeps!!!:ringaroun

Fire-scryer
October 31st, 2007, 12:58 AM
So, I'm a Ranger (Level 7 presently) and I've had the abilitiy to call an animal familiar (i picked the panther) since level six, but I CAN'T do it, I can use my ranger spells and stuff but when I try and call my animal familiar from my special abilities it won't let me, the only thing I can do is cast defensive magic or something. I tried taking off my armor on the off chance that it was giving me a problem as if I were a mage, but no such luck. Anyone know what I'm doing wrong here? Its not like the normal spells where you assign it a spot and then rest to memorize them and the manual isn't helpful at all. Any help would be appreciated. Thanks, peeps!!!:ringaroun

I have never played a ranger but I have a sorcerer and he has a familiar as well. I know every time you level, it "resets" your familiar so he can level with you. Try right clicking and finding the summon familiar spell through the tree that way rather than using the old hotkey on the spell bar. I have had problems with the hotkey not working after a level.

Familiar use is once per day so you do have to rest when recasting him as well.

Hope this helps, I will do some research on it and see what I can come up with. When I go back to the room tonight I will try and duplicate the problem with a ranger and see what I get.

What expansion are you running?